SAS Web Report Studio 3.1 Doesn’t Like Newer Browsers

By | February 6, 2009

SAS developed Web Report Studio (9.1.3 BI Server installation) for Internet Explorer 6.0. I have used IE 7.0 and Firefox 2.x and 3.x with Web Report Studio and ran into a few different Javascript errors. These errors don’t necessarily make Web Report Studio completely unusable, you just have to know what NOT to do. To save everybody from having to learn what not to do, you have a couple of options. You could stick with IE6.  How old is that technology?  I recently ran across another option which utilizes Firefox as the browser at the SAS BI-ogsource (http://sas-bi.blogspot.com/2007_08_01_archive.html):

IE 7 Headaches – Try Firefox

Once you have mistakenly loaded IE 7 and can no longer use the SAS web applications, you’ll find that reverting back to IE 6 will take an act of congress. (Really, and you know how slow they are.)

Use Firefox and install their IE tab. You can download it from the site:

https://addons.mozilla.org/en-US/firefox/browse/type:1

posted by Angela Hall @ 8/26/2007 0 comments

I installed the IE Tab Add-On in Firefox and Web Report Studio works just like I’m running IE6 (probably even better). In the options for IE Tab, I had to include my Tomcat server name and port in the sites filter so Firefox knows when to use the add-on.

Like many of the SAS promises, IE7 and FireFox support should be included in the 9.2 version of BI Server, so maybe everything will work like it is supposed to in a few months.  9.2 is shipping in Q1, right?

Leave a Reply

Your email address will not be published. Required fields are marked *